Username
Forgot password?
Welcome to our site!
Or Join with FTTF

404 error in index.php

0

3878 views
Hi Dimitri,

Let me first congratulate and thank you for this amazing software. You've done a great job and have allowed people with little programming experience to come close to launching products based on your code.

I've successfully installed LampCMS on an EC2 instance and everything works great, nginx, mongo, everything seems ok. However, I keep getting emails about a 404 error in index.php, even though I haven't accessed the website that day. Although it is on a public domain, I doubt it has been parsed by Google yet and I am the only one who knows about it. I can't help but think that these are attacks on the website, could you please confirm this for me based on the following content of those emails?

I've used "******************" to reply the server's IP, thought it would be best in a public forum.

Your help will be much appreciated. Thank you.

$_SERVER: Array
(
  [USER] => www-data
  [HOME] => /var/www
  [FCGI_ROLE] => RESPONDER
  [SCRIPT_FILENAME] => /usr/share/nginx/html/www/index.php
  [QUERY_STRING] => 
  [REQUEST_METHOD] => GET
  [CONTENT_TYPE] => text/html
  [CONTENT_LENGTH] => 
  [SCRIPT_NAME] => /index.php
  [REQUEST_URI] => /manager/html
  [DOCUMENT_URI] => /index.php
  [DOCUMENT_ROOT] => /usr/share/nginx/html/www
  [SERVER_PROTOCOL] => HTTP/1.1
  [GATEWAY_INTERFACE] => CGI/1.1
  [SERVER_SOFTWARE] => nginx/1.2.6
  [REMOTE_ADDR] => 220.165.88.21
  [REMOTE_PORT] => 4558
  [SERVER_ADDR] => *************1
  [SERVER_PORT] => 80
  [SERVER_NAME] => *************2
  [HTTPS] => 
  [REDIRECT_STATUS] => 200
  [HTTP_CONTENT_TYPE] => text/html
  [HTTP_HOST] => *************3
  [HTTP_ACCEPT] => text/html, */*
  [HTTP_USER_AGENT] => Mozilla/3.0 (compatible; Indy Library)
  [HTTP_AUTHORIZATION] => Basic Og==
  [PHP_SELF] => /index.php
  [PHP_AUTH_USER] => 
  [PHP_AUTH_PW] => 
  [REQUEST_TIME_FLOAT] => 1375630759.029
  [REQUEST_TIME] => 1375630759
)


REQUEST HEADERS: {"Content-Type":"text\/html","Content-Length":"","Host":"*************4","Accept":"text\/html, *\/*","User-Agent":"Mozilla\/3.0 (compatible; Indy Library)","Authorization":"Basic Og=="}

Exception class: Lampcms\Lampcms404Exception
Message:Page you looking for does not exist
 in file: /usr/share/nginx/html/lib/Lampcms/SplClassLoader.php
 line: 195
 trace: #0 [internal function]: Lampcms\SplClassLoader->loadClass('Lampcms\Control...')
#1 /usr/share/nginx/html/www/index.php(123): spl_autoload_call('Lampcms\Control...')
#2 {main}


 
asked August 5, 2013 at 4:32 AM

 ro
I know this is not related, but could you post your nginx server {} config? I just want to compare mine with yours and see if I could be missing anything. I'm not getting errors, but would like to compare is all. Cheers
flag
Aug 6, 2013 01:51 AM

0 Answers

Be the first to answer this question

Join with account you already have

FTTF

Preview

Alert